Knowledge Base / FAQ

Date: 2018-05-20   |   ID: KB00256EN   |   short link:

Can I use U108 PRE under Windows XP?

No. U108 PRE is not compatible with Windows XP. The interface is using a newer version of our driver engine that only supports Windows Vista and later, Windows 7 or higher is strongly recommended.

Related products

More support pages

Tags


 WinXP   driver 

Download


KB00256EN.pdf