Knowledge Base / FAQ

Date: 2014-09-27   |   ID: KB00217EN   |   short link:

Are Juli@ and Juli@ XTe driver compatible?

Yes, Juli@ and Juli@ XTe are 100% driver compatible - under any operating system.

Related products

  • Juli@ - PCI/PCIe Audio Interfaces
  • Juli@ XTe - PCI/PCIe Audio Interfaces

More support pages

Tags


 driver   compare 

Download


KB00217EN.pdf